Настройка mikrotik через usb

Настройка MikroTik RB951Ui-2Hnd для работы с 3G/4G/LTE модемом

В данной статье рассмотрим настройку роутера RB951Ui-2Hnd с модемом Huawei E3372 с прошивкой hilink.

1. Заходим в web интерфейс роутера через браузер и скачивает утилиту winbox. Для этого меняем настройки вашей локальной сети на ip 192.168.88.100 и набираем в адресной строке ip роутера по умолчанию 192.168.88.1 и видим следующее окно:

В левом нижнем углу нажимаем на winbox и начинается автоматическая загрузка.

2. Заходим в наш роутер через winbox, вводим ip роутера и логин: admin, нажимаем на connect.

3. После входа в MikroTik RB951Ui-2Hnd подсоединяем к нему Huawei E3372 и должны увидеть во вкладке Interface наш модем определенный как LTE, если прошивка не hilink, а модем от провайдера (Мегафон, Билайн или МТС) то скорей всего он определится как (ppp-out1).

Для того чтобы включить наш модем, нужно нажать на LTE правой кнопкой мыши и выбрать Enable.

4. Следующий этап, идем в ip — DHCP Client и добавляем наш LTE модем.

Жмем на (+) и видим такую табличку:

В окне interface выбираем LTE , а если у Вас модем определился как ppp-out1, тогда выбираете его. В окне Default Route Distance ставите значение (1). Нажимаем Apply и OK.

5. Направляемся во вкладку Firewall (ip-Firewall) и выключаем все Красным крестиком, кроме Default configuration.

Далее нажимаем на Default configuration два раза и в окне Firewall Rule в разделе Chain ставим input, а в окне In.interface выбираем наш LTE, нажимfем Apply и переходи во вкладку Action:

Выбираем Accept, нажимаем Apply и OK.

6. Следующий этап, это настройка NAT, без него интернета не будет. Переходим опять в ip-firewall и нажимаем на вкладку NAT:

В окне Chain ставим srcnat и в Out.interface выбираем наш LTE. Все применяем и переходи в раздел Action:

Тут мы выбираем в окне Action действие masquerade жмем Apply и OK. Теперь у нас появился интернет на Микротике и можем его проверить перейдя в New Terminal:

Тут пишем команду «ping» и любой сайт, в нашем случае тут «ya.ru» Вим что пошел пинг, значит все сделано правильно. Дополнительные настройки включают в себя настройку DHCP сервера для автоматической раздачи ip адресов, кому это не нужно можно прописать на ПК статику и все будет работать.

А вот наш замер скорости данного роутера RB951Ui-2Hnd и Модема Huawei E3372 с внешней антенной:

Источник

3G Модем и MikroTik

Настройка модема

У MikroTik RouterBoard 951g-2hnd один USB порт. Для удобства я подключил 3G модем через маленький USB удлинитель и приступил к настройкам:

Смотрим какие устройства нам доступны по USB:
system resource usb print
# DEVICE VENDOR NAME SPEED
1 1:2 ZTE,Incorporated ZTE WCDMA Technologies MSM 480 Mbps

Смотрим порты, а главное количество каналов (3 канала от 0 до 2):
port print
Flags: I — inactive
# NAME CHANNELS USED-BY BAUD-RATE
0 usb1 3 9600

Теперь подключимся к модему и настроим его работу (канал выбираем перебором, ожидая на ввод команды AT ответ OK. У меня получилось с 1 и 2 каналом.):
system serial-terminal port=usb1 channel=1
[Ctrl-A is the prefix key]
AT
OK

Читайте также:  Подключить принтер самсунг к роутеру

Сначала сбросим к заводским настройкам:
AT&F
OK

Посмотрим на наш модем:
ATI
Manufacturer: ZTE CORPORATION
Model: MF112
Revision: BD_MF112V1.0.0B01
IMEI: 35***********54
+GCAP: +CGSM,+DS,+ES
OK

Проверим блокировку сети/SIM
AT+ZSEC?
+ZSEC: 3,0
OK

тут +ZSEC: N,X
N — Статус блокировки сети:
0 Инициализация шифрования (Незначительные SEC_ITEMS)
1 Network Lock ошибки. (Незначительные SEC_ITEMS)
2 Сетевая блокировка
3 разблокирована или исправить MCC/MNC

X — Статус блокировки SIM:
0 Нет действий
1 Сеть Lock
2 (U) SIM-карты Блокировка
3 Сеть Lock и (U) SIM-карты Блокировка

Уровень сигнала:
AT+CSQ
+CSQ: 17,99
OK

В децибелах (X = 17): -113 + X * 2 = -113 + 17 * 2 = -79 дБ

Узнать SIM IMSI номер:
AT+CIMI
25***********56
OK

Далее отключаем виртуальный CDROM:
AT+ZCDRUN=E
Enter download mode result(0:FAIL 1:SUCCESS):1
OK

AT+ZCDRUN=8
Close autorun state result(0:FAIL 1:SUCCESS):1
OK

Выбираем режим работы:
AT+ZSNT=0,0,0 (Авто) — по умолчанию
AT+ZSNT=0,0,1 Автоматический выбор сети: GSM+WCDMA, предпочтение GSM
AT+ZSNT=0,0,2 Автоматический выбор сети: GSM+WCDMA, предпочтение WCDMA
AT+ZSNT=1,0,0 Автоматический выбор сети: только GSM
AT+ZSNT=2,0,0 Автоматический выбор сети: только WCDMA
AT+ZSNT=0,1,0 Ручной выбор сети: GSM+WCDMA
AT+ZSNT=1,1,0 Ручной выбор сети: только GSM
AT+ZSNT=2,1,0 Ручной выбор сети: только WCDMA

Я выбрал Автоматический выбор сети: GSM+WCDMA, предпочтение WCDMA:
AT+ZSNT=0,0,2
OK

Все теперь сохраняем данные в текущем профиле:
AT&W
OK

Жмем Ctrl-A
[Q — quit connection] [B — send break]
[A — send Ctrl-A prefix] [R — autoconfigure rate]

Настройка подключения

Для этого нам нужны следующие исходные данные (пример на операторе MTS):

  • APN: internet.mts.ru
  • Phone: *99#
  • User: mts
  • Password: mts

Кроме того:

  • порт к которому подключен модем: usb1
  • номера data и info каналов: 2 и 1 (подобрал перебором)

В интерфейсах должно появится новое соединение ppp-out1:
interface print
Flags: D — dynamic, X — disabled, R — running, S — slave
# NAME TYPE MTU L2MTU MAX-L2MTU MAC-ADDRESS
12 X ppp-out1 ppp-out

Настроем его:

и подключим:

Получение/Отправка SMS

Интерне есть, но за него надо платить, а для этого нужно следить за балансом. Для этого я воспользовался SMS-помощником. Можно пользоваться и USSD запросами (#100# узнать баланс у MTS), но доступны они только через консоль, команда вида:
AT+CUSD=1,#100#,15
В ответ получим:
OK
И через некоторое время строку:
+CUSD: 0,»00420061006C0061006E00630065003A00370031002C0032003000720020″,72
Сообщение «00420061006C0061006E00630065003A00370031002C0032003000720020» — это сообщение в UCS-2 кодировки, которое можно расшифровать используя этот ресурс.
Данный подход не очень то удобный, по этой причине пользоваться SMS-помощником уместнее.

У MTS, чтобы получить SMS с балансом нужно отправить сообщение на номер 111 с текстом 11. Делается это так (канал выбран перебором):
tool sms send usb1 phone-number=111 message=11 channel=1

Далее читаем входящие сообщения и ждем наше (secret равен любой строке):
tool sms set channel=1 port=usb1 keep-max-sms=10 receive-enabled=yes secret=blabla
tool sms inbox print

Получаем пустое сообщение от 111. Дело в том что Mikrotik может работать только с текстовыми SMS сообщениями, а вот с PDU нет.
Необходимо заставить SMS-помощника присылать сообщения в текстовом виде. Для этого достаточно отправить SMS на номер +79126313431 с текстом Eng (Это для оператора MTS):

tool sms send usb1 phone-number=+79126313431 channel=1 message=Eng

Смотрим:
tool sms inbox print
# PHONE TIMESTAMP MESSAGE
0 +79126313431 Jul/30/2013 14:08:40 GMT +6 Now you are a default language user
1 111 Jul/30/2013 14:07:33 GMT +6

Пробуем еще раз получить баланс:
tool sms send usb1 phone-number=111 message=11 channel=1
Смотрим:
tool sms inbox print
# PHONE TIMESTAMP MESSAGE
0 111 Jul/30/2013 14:09:20 GMT +6 Vash balans:117,5 rub. sms
1 +79126313431 Jul/30/2013 14:08:40 GMT +6 Now you are a default language user
2 111 Jul/30/2013 14:07:33 GMT +6

Читайте также:  Роутеры для бесшовного wifi

Теперь мы можем принимать SMS сообщения.

Тариф

Я опишу лишь MTS т.к. его SIM карта была у меня (собственно как и модем — но это исправимо)

Тариф: Супер МТС и главное это опция «МиниБИТ», которая позволяет платить за интернет, только в тот день, когда он нам необходим — 15руб. Минус это суточная квота в 5 Мбайт, далее скорость падает до 32Кбит/с.

Тариф: Коннект-4 (Переход на этот тариф доступен не со всех тарифов) и опция «Интернет на день», она позволяет платить за интернет, только в тот день, когда он нам необходим — 30руб. Минус это суточная квота в 250 Мбайт, далее скорость падает до 64Кбит/с.

Если кто знает более выгодные подобные тарифы/опции, то поделитесь пожалуйста.

Вот так вот я организовал аварийный интернет-канал на всякий случай.

Источник

Mikrotik и USB модем

Данная инструкция рассчитана на настройку нового Микротика с пустой конфигурацией.
Если Ваш Микротик уже содержит старые конфигурации, то необходимо их сбросить.
Как это сделать, можно посмотреть в инструкции по настройке (шаг 1-3).

Mikrotik с USB модемом удобно использовать в связке.

Где это может пригодиться? В местах, где нет проводного интернета.
Например, в труднодоступных и отдалённых местах или в транспорте.
В этой статье мы покажем, как настроить интернет на Микротике через USB модем.

При подключении USB модема автоматически появляется новый интерфейс ppp-out1
Он по умолчанию выключен

Если зайти в свойства интерфейса и посмотреть информацию (кнопка Info справа в меню), то можно увидеть более подробные сведения:
Модель USB модема, ревизию, серийный номер, название оператора, режим работы (3G/LTE), уровень сигнала.

Если информация автоматически не появилась — нажмите в окне PPP info кнопку Start.
В некоторых моделях информация может быть недоступна, если интерфейс USB модема включен.

Чтобы появился интернет через подключенный USB модем, необходимо включить интерфейс:

После этого у Вас есть несколько вариантов настройки Микротика:

Вариант 1

Настроить интернет с открытым доступом для личного пользования.
Для этого достаточно скопировать следующий скрипт и вставить его в терминал Микротика

/ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/interface bridge add name=inet-bridge
/ip pool add name=inet-pool ranges=192.168.100.2-192.168.103.253
/ip dhcp-server add address-pool=inet-pool disabled=no interface=inet-bridge lease-time=12h name=inet-dhcp
/interface bridge port add bridge=inet-bridge interface=wlan1
/ip address add address=192.168.100.1/22 comment=»Internet network» interface=inet-bridge network=192.168.100.0
/ip dhcp-server network add address=192.168.100.0/22 comment=»Internet network» dns-server=8.8.8.8,208.67.222.222 gateway=192.168.100.1 netmask=22
/ip firewall nat add action=masquerade chain=srcnat comment=»masquerade Internet network» src-address=192.168.100.0/22
/interface wireless set wlan1 mode=ap-bridge ssid=WiFi_USB default-forwarding=no disabled=no

Вариант 2

Настроить интернет с авторизацией для публичных мест.
В этом случае достаточно скопировать готовый скрипт для Микротика из Личного кабинета.

Как это выглядит в жизни.

Один из примеров — использование Wi-Fi в автотранспорте.

Подключаем настроенный Микротик к автомобильному питанию. Мы использовали автомобильную зарядку на 12V.

В телефоне включили Wi-Fi и подключились к нашему Микротику.

Как видно — интернет появился. Скорость зависит от типа модема и качества связи в данной местности.

Источник

MikroTik настройка USB модема для доступа в интернет

В данной статье мы поговорим о том, как настроить MikroTik usb модем для выхода в интернет. Обычно, данную технологию применяют, когда нет другой возможности подключения к глобальной сети, либо используют lte модем как резервный канал связи.

Научиться настраивать MikroTik с нуля или систематизировать уже имеющиеся знания можно на углубленном курсе по администрированию MikroTik. Автор курса, сертифицированный тренер MikroTik Дмитрий Скоромнов, лично проверяет лабораторные работы и контролирует прогресс каждого своего студента. В три раза больше информации, чем в вендорской программе MTCNA, более 20 часов практики и доступ навсегда.

Для данного примера мы будем использовать роутер MikroTik hAP ac lite с 4g модемом Huawei E3372h и сотовым оператором Yota.

Читайте также:  Настройка mikrotik sxt lite2 sxt 2ndr2

Выбор usb модема для Микротик

Сегодня на рынке присутствует огромное количество различных модемов, но не все они способны работать на маршрутизаторах данного бренда. Для MikroTik USB модем должен быть в списке поддерживаемых устройств, ознакомиться с которым можно на официальной Wiki-странице: https://wiki.mikrotik.com/wiki/Manual:Peripherals.

Настройка usb модема Yota на Микротик

Прежде чем настроить MikroTik usb модем, выполним сброс роутера до чистой конфигурации. Для этого откроем конфигурацию RouterOS через Winbox и произведем действия:

В открывшемся окне:

После того как устройство перезагрузится, зайдем на Микротик по MAC-адресу.

Прежде чем приступить к дальнейшей настройке устройства, не забудьте установить пароль администратора.

Следующим шагом откроем вкладку “Interfaces”, затем подключим к MikroTik Yota modem, вставив его в USB-порт устройства:

Через некоторое время мы увидим, что появился новый LTE-интерфейс.

Если на роутере Микротик есть Wi-Fi модуль 2,4 ГГц, то рекомендуем подключать LTE modem через USB-удлинитель, что может увеличить скорость соединения.

Это объясняется тем, что частоты LTE и Wi-Fi 2,4 ГГц близки по значениям. Подключая modem кабелем USB, мы разносим два передатчика друг от друга, что и позволяет улучшить скорость интернет-подключения.

Чтобы облегчить дальнейшую настройку конфигурации и сделать ее более универсальной (например, захотим добавить второго провайдера), создадим новый “Interface List”:

Добавим в него LTE соединение:

Переходим к настройке DHCP-Клиента на LTE-интерфейсе. Откроем:

  • IP => DHCP Client.

Как мы видим на MikroTik Yota модем создал динамическую запись DHCP-клиента назначив роутеру DNS-сервера и маршрут по умолчанию, которые мы не можем изменить. Это может вызвать трудности при дальнейшей модернизации конфигурации RouterOS.

Поэтому удалим текущую запись:

И создадим ее заново, указав необходимые параметры вручную:

  • Использовать ДНС (Use Peer DNS);
  • Добавление маршрута по умолчанию (Add Default Route).

Активируем созданную запись:

Двойным нажатием откроем свойства подключения и на вкладке “Status” посмотрим текущие значения:

  • IP Address: 192.168.8.100/24 – адрес, присвоенный подключению;
  • Gateway: 192.168.8.1 – IP-адрес шлюза, который нам необходимо прописать для маршрута по умолчанию.

  • IP => Routes => “+”.

Следующим шагом добавим записи для DNS-Сервера:

Подробнее о настройке службы доменных имен вы можете узнать из статьи: Настройка DNS Server на MikroTik.

Осталось создать правило трансляции сетевых адресов (NAT):

На вкладке “General” выбираем цепочку srcnat и указываем Out. Interface List:

Далее откроем пункт меню “Action”:

На этом настройка интернет-доступа для MikroTik через USB modem закончена.

Обратите внимание, что при текущей конфигурации RouterOS не настроена LAN-сеть.

Чтобы компьютеры внутри локальной сети получали сетевые параметры для доступа в интернет, необходимо:

  • Объединить нужные порты в Bridge;
  • Указать IP-адрес подсети;
  • Настроить DHCP Server;
  • Включить и настроить Wi-Fi интерфейсы.

Надеюсь, данная статья была полезна. Если остались вопросы, то пишите комментарии.

Научиться настраивать MikroTik с нуля или систематизировать уже имеющиеся знания можно на углубленном курсе по администрированию MikroTik. Автор курса, сертифицированный тренер MikroTik Дмитрий Скоромнов, лично проверяет лабораторные работы и контролирует прогресс каждого своего студента. В три раза больше информации, чем в вендорской программе MTCNA, более 20 часов практики и доступ навсегда.

Источник

Adblock
detector