Mikrotik spi грузит процессор что это

Alexell.Ru

Официальный сайт Alexell

FastTrack на MikroTik — уменьшаем нагрузку на CPU

Добрый вечер, уважаемые читатели моего скромного блога! Прошу прощения, что давно ничего не писал, я был занят одним проектом, да и идей особо не было. Однако сегодня я хочу поделиться с вами своей историей о нагрузке на CPU моего MikroTik hAP ac. Вы узнаете про FastTrack и оптимизацию Firewall.

Итак, что мы имеем:

  • 2 постоянно работающих L2TP+IPSec подключения
  • 18 правил Firewall
  • 13 правил NAT
  • 3 правила Mangle
  • 10 скриптов в Scheduler (5 из которых выполняются каждую минуту)
  • Один игровой сервер
  • Один личный компьютер
  • Мобильные устройства

Все это дело вроде бы работало без сбоев, пока однажды, когда я был на работе, у меня не пропала связь с Микротиком. Поскольку я работаю в провайдере и от него же у меня дома интернет, я зашел в биллинг — интернет оплачен, сессии нет. Зашел на свитч — линк на порту есть, ошибки не копятся, но маки не приходят. Перезагрузка порта не помогла.

Когда я наконец пришел домой после смены, было похоже что Микротик завис. Лампочки горели, но DHCP он не раздавал, по MAC к нему подключиться тоже не удалось. После его перезагрузки связь восстановилась. Подозреваю что причиной стала высокая и длительная нагрузка на CPU, но выяснил я это уже позже. Как оказалось, при скачивании торрента на компьютере со скоростью 25-30 МБ/сек, нагрузка на CPU Микротика держится в районе 90-100%. А перед уходом на работу я как раз поставил скачиваться 5 сезонов сериала.

Как же я решил проблему высокой нагрузки на CPU MikroTik?

Источник

ИТ База знаний

Курс по Asterisk

Полезно

— Узнать IP — адрес компьютера в интернете

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Калькулятор инсталляции IP — АТС Asterisk

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

Высокая загрузка процессора Mikrotik. Что делать?

4 минуты чтения

Сетевое оборудование вендора Mikrotik является весьма любопытным и привлекательным продуктом в сегменте SOHO (Small office/home office). Соотношение цены, качества, функционала и стабильности обеспечивает все большее распространение небольших белых коробочек в офисах небольших компаний.

Онлайн курс по Кибербезопасности

Изучи хакерский майндсет и научись защищать свою инфраструктуру! Самые важные и актуальные знания, которые помогут не только войти в ИБ, но и понять реальное положение дел в индустрии

Но спустя какое-то время беззаботного пользования, пользователи начинают жаловаться. Администратор, открыв Winbox, переходит в раздел SystemResources и видит, что загрузка процессора 100%:

Не стоит волноваться. У нас есть решение. Все настройки и «траблшутинг» будем осуществлять с помощью Winbox.

Настройка Firewall в Mikrotik

Первым делом давайте проверим службу, которая больше всего «отъедает» ресурсов процессор. Для этого, перейдем в раздел ToolsProfile:

Читайте также:  Настроить роутер trendnet tew 652bru

Как видно из скриншота, львиную долю ресурсов нашего процессора занимает служба DNS. Давайте посмотрим, что происходит на уровне обмена пакетами на основном интерфейс ether1. Для этого воспользуемся утилитой ToolsTorch:

Мы видим большое количество пакетов с различных IP – адресов на 53 порт. Наш Mikrotik отвечает на каждый из таких запросов, тем самым, нерационально используя ресурсы процессора и повышая температуру.

Эту проблему надо решать. Судя по снятому дампу, пакеты приходят с частотой 10-20 секунд с одного IP – адреса. Добавим в наш Firewall два правила:

  1. Все IP – адреса, пакеты с которых приходят на 53 порт нашего Микротика будут помещаться в специальный лист с названием dns spoofing на 1 час.
  2. Каждый IP – адрес, с которого будет поступать запрос на 53 порт будет проверяться на предмет нахождения в списке dns spoofing . Если он там есть, мы будем считать, что это DNS – спуфинг с частотой реже чем раз в час и будем дропать данный пакет.

Переходим к настройке. В разделе IPFirewallFilter Rules создаем первое правило нажав на значок «+». Во кладке General указываем следующие параметры:

  • Chain = input — обрабатываем приходящие пакеты
  • Protocol = UDP — нас интересуют пакеты, у которых в качестве транспорта используется UDP
  • Dst. Port = 53 — портом назначения должен быть 53 порт, то есть DNS служба
  • In. Interface = ether1 — проверка подвергаются все пакеты, которые приходят на интерфейс ether1, который смотрит в публичную сеть.

Переходим во вкладку Action:

  • Action = add src to address list — в качестве действия, мы будем добавлять IP – адрес источника в специальный лист
  • Address List = dns spoofing — указываем имя листа, в который добавляем IP
  • Timeout = 01:00:00 — добавляем на 1 час

Нажимаем Apply и OK. Настроим второе правило, так же нажав на «+»:

Как видно, настройки во вкладке General в данной вкладке идентичны первому правилу. Нажимаем на вкладку Advanced:

  • Src. Address List= dns spoofing — указываем Микротику, производить проверку приходящего пакета на предмет нахождения в указанном листе

Переходим во вкладку Action:

  • Action = drop — если IP – адрес пакета есть в указанном списке, то дропаем этот пакет.

После того, как оба правила стали активны переходи во вкладку IPFirewallAddress Lists:

Как видно, адреса стали добавляться в список на 1 час. Теперь давайте проверим загрузку процессора:

Теперь загрузка процессора в пределах нормы. Проблема решена.

Полный курс по Сетевым Технологиям

В курсе тебя ждет концентрат ТОП 15 навыков, которые обязан знать ведущий инженер или senior Network Operation Engineer

Источник

Mikrotik spi грузит процессор что это

Tue Oct 22, 2013 10:33 am

Re: What is Tools->Profile->SPI usage??

Tue Oct 22, 2013 12:45 pm

Re: What is Tools->Profile->SPI usage??

Mon Nov 04, 2013 8:54 am

Re: What is Tools->Profile->SPI usage??

Mon Nov 04, 2013 3:24 pm

Re: What is Tools->Profile->SPI usage??

Mon Nov 04, 2013 10:13 pm

Re: What is Tools->Profile->SPI usage??

Tue Nov 05, 2013 9:31 am

Re: What is Tools->Profile->SPI usage??

Tue Nov 05, 2013 6:38 pm

Re: What is Tools->Profile->SPI usage??

Tue Nov 05, 2013 7:31 pm

Re: What is Tools->Profile->SPI usage??

Wed Nov 06, 2013 9:20 am

RB750, 450 and 493 do not have possibility for any external memory, not even USB.

Yesterday I was having problems again with the 493 .. I decide to disable the local cache from Web Proxy because again SPI and Unclassified takes 20-30 % of CPU and machine was slow responsive.

Strange thing is that WAN interface showed only a traffic of 15-20 mbps. so it seems the CPU of this machines was designed with NO CACHE in mind.

Re: What is Tools->Profile->SPI usage??

Wed Nov 06, 2013 9:56 am

Re: What is Tools->Profile->SPI usage??

Wed Nov 06, 2013 1:38 pm

Читайте также:  Лентел настройка роутера tp link

I perfectly agree with you. this equipment’s are installed in QUITE EXTREME REMOTE areas far from civilized world replacing x86 computers before. (because of the space and low power consumption requirements).

We will focus setting cache on none and using Proxy Cluster cache.

Re: What is Tools->Profile->SPI usage??

Wed Jan 14, 2015 12:05 pm

Re: What is Tools->Profile->SPI usage??

Fri May 12, 2017 6:28 pm

We will contribute to keep you updated!

Re: What is Tools->Profile->SPI usage??

Fri Aug 04, 2017 10:22 pm

SPI stands for Serial Peripheral Interface. It is one of the buses on the router that is used to talk to certain components, like the LCD panel as previously stated. Anyone that has ever message with an Arduino should be familiar with this type of bus.
https://en.wikipedia.org/wiki/Serial_Pe . erface_Bus

I was seeing 30% CPU utilization on a router today and all of the usage was on SPI. I went into the LCD configuration and changed it to «Read Only Mode» and the usage dropped down to 2-4% for SPI in the profile tool and now the router is sitting at

8% CPU utilization with SPI only using 2-4% periodically, which makes sense because if that is the router updating the LCD screen and I am running the «stats slideshow» for the WAN interface on the LCD, so I would expect some CPU utilization there as it updates the graphs.

Re: What is Tools->Profile->SPI usage??

Fri Aug 04, 2017 10:33 pm

Re: What is Tools->Profile->SPI usage??

Sat Aug 05, 2017 3:53 am

I would think that would fall under the category of firewall as conntrack is a component of iptables.

Unfortunately I cant find any instance of where anyone from Mikrotik has officially documented what spi in the profile tool actually means. My comments are based purely on observed behavior of the platform.

Re: What is Tools->Profile->SPI usage??

Sat Aug 05, 2017 2:22 pm

Re: What is Tools->Profile->SPI usage??

Mon Jul 22, 2019 9:45 pm

SPI stands for Serial Peripheral Interface. It is one of the buses on the router that is used to talk to certain components, like the LCD panel as previously stated. Anyone that has ever message with an Arduino should be familiar with this type of bus.
https://en.wikipedia.org/wiki/Serial_Pe . erface_Bus

I was seeing 30% CPU utilization on a router today and all of the usage was on SPI. I went into the LCD configuration and changed it to «Read Only Mode» and the usage dropped down to 2-4% for SPI in the profile tool and now the router is sitting at

8% CPU utilization with SPI only using 2-4% periodically, which makes sense because if that is the router updating the LCD screen and I am running the «stats slideshow» for the WAN interface on the LCD, so I would expect some CPU utilization there as it updates the graphs.

Источник

Mikrotik spi грузит процессор что это

Thu Apr 12, 2018 11:25 am

RB941 is running on high CPU Load which in turn is causing high internet latency
The /system profile shows Management at 40% and SPI at 30% which are causing most of the load.

I have even disabled SNMP and Traffic Flow but that does not seem to help. Kindly advise what could be causing this to happen and how to resolve

Kind Regards,
Cedric

Re: RB941 running on high CPU Load — SPI and Management

Thu Apr 12, 2018 2:25 pm

30% on SPI may be normal depending on your traffic and on whether you use fasttracking or not. What surprises me is 40% on management.

What is connected at the private (LAN) side of your Mikrotik, what kind of traffic do you expect (live videos, just web pages), and what does

Читайте также:  Что делать если забыл пароль от роутера d link dir 615

Re: RB941 running on high CPU Load — SPI and Management

Thu Apr 12, 2018 3:18 pm

Please find below /export hide-sensitive. There is DVR traffic and web/email users, also port forwarding for RDP and DVR

Re: RB941 running on high CPU Load — SPI and Management [SOLVED]

Thu Apr 12, 2018 4:27 pm

I can also see that you haven’t restricted access to http (www) management interface using any other means than the firewall filter.

Together with software version 6.34.1, I would be afraid that your machine has been infected by malware exploiting the vulnerability of http server as described here and that the load could be coming from the activity of this malware. So the first thing to do would be to upgrade to 6.40.7 if you want to avoid 6.41.x for the moment. Then I would check the

Источник

Mikrotik spi грузит процессор что это

Бесплатный чек-лист
по настройке RouterOS
на 28 пунктов

Высокая загрузка процессора на RB951G-2HnD

Добрый день.
Настроил товарищу дома RB951G-2HnD 6.42.6.
— адрес от провайдера по DHCP
— 2 порта в бридже, к ним подключены телевизоры и настроен IGMP Proxy, своя подсеть и свой DHCP
— 1 порт в бридже с wlan

Firewall — самый стандартный:
0 chain=input action=accept protocol=tcp in-interface=ether1 dst-port=8291 log=no log-prefix=»»
1 chain=input action=accept protocol=icmp log=no log-prefix=»»
2 chain=input action=add-src-to-address-list protocol=udp address-list=dns flood address-list-timeout=1h1m in-interface=ether1
dst-port=53 log=no log-prefix=»»
3 chain=input action=drop protocol=udp src-address-list=dns flood in-interface=ether1 log=no log-prefix=»»
4 chain=input action=accept connection-state=established log=no log-prefix=»>
5 chain=input action=accept connection-state=related log=no log-prefix=»»
6 chain=forward action=accept connection-state=established log=no log-prefix=»»
7 chain=forward action=accept connection-state=related log=no log-prefix=»»
8 chain=input action=accept in-interface=!ether1 log=no log-prefix=»»
9 chain=forward action=accept in-interface=!ether1 out-interface=ether1 log=no log-prefix=»»
10 ;;; Allow IGMP
chain=input action=accept protocol=igmp in-interface=ether1
11 ;;; IPTV UDP incoming
chain=input action=accept protocol=udp in-interface=ether1 dst-port=1234
12 ;;; IPTV UDP forwarding
chain=forward action=accept protocol=udp dst-port=1234
13 chain=input action=drop connection-state=invalid log=no log-prefix=»»
14 chain=forward action=drop connection-state=invalid log=no log-prefix=»»
15 chain=forward action=drop log=no log-prefix=»»

Через несколько дней началось замирание раз в несколько секунд картинки IPTV. При этом загрузка процессора прыгает до 100%. В tools\Profile видно, что основную нагрузку создает management, но сама причина не понятна. Попробовал идти методом исключения: отключал по очереди внутренние интерфейсы. С уменьшением числа подключенных устройств нагрузка падает, но даже при их отсутствии (и отключенных бриджах) прыгает до 9%. До этого стоял RB951Ui-2HnD 6.39.3 и таких проблем не наблюдалось. В какую сторону копать?

Работал-работал мой роутер с 2014 года и бед я не знал. однажды, пару лет назад, была возможность заменить его на новый. Заменил. Бесплатно. И продолжал жить с ним без бед.

А вот в начале года я решил актуализировать на нём версию RouterOS, обновить приложения и прошивку. Обновил. И стал замечать, что происходит ерунда какая-то с интернетом на домашних устройствах. Сначала начал искать корень проблемы в кабелях, коннекторах и прочем подобном. Но корень зла нашелся в роутере, чего я не ожидал.

Что имею. В случаях, когда все подключенные к роутеру устройства (в том числе и беспроводные), очень хорошо нагружают входящий канал, CPU роутера нагружен в диапазоне 90-100%. На некоторых устройствах (особенно беспроводных) начинается дикая потеря пакетов на пути к роутеру. Интернет начинает тупить жутко. На телевизорах, к примеру (подключены кабелем), Youtube или Кинопоиск останавливаются и ждут подгрузки видео.

Если при этом ещё и Skype где-то запустить, всё — конец.

Так вот, до обновления прошивки я не замечал таких проблем. Сейчас же, если беспроводное устройство качает что-то на скорости 20-30 Мбит, CPU загружен, в среднем, на 90%.

Что происходит? Есть у вас идеи или советы? В tools \ profile основную нагрузку дает Netwroking.

Я пробовал отключать всё, что у меня есть в ip firewall filter, ip firewall mangle и в queues tree. Это снижает нагрузку на CPU до 70%. Но без этого всего мне совсем не хочется работать с роутером.

Источник

Mikrotik spi грузит процессор что это

Alexell.Ru

Официальный сайт Alexell

FastTrack на MikroTik — уменьшаем нагрузку на CPU

Добрый вечер, уважаемые читатели моего скромного блога! Прошу прощения, что давно ничего не писал, я был занят одним проектом, да и идей особо не было. Однако сегодня я хочу поделиться с вами своей историей о нагрузке на CPU моего MikroTik hAP ac. Вы узнаете про FastTrack и оптимизацию Firewall.

Итак, что мы имеем:

  • 2 постоянно работающих L2TP+IPSec подключения
  • 18 правил Firewall
  • 13 правил NAT
  • 3 правила Mangle
  • 10 скриптов в Scheduler (5 из которых выполняются каждую минуту)
  • Один игровой сервер
  • Один личный компьютер
  • Мобильные устройства

Все это дело вроде бы работало без сбоев, пока однажды, когда я был на работе, у меня не пропала связь с Микротиком. Поскольку я работаю в провайдере и от него же у меня дома интернет, я зашел в биллинг — интернет оплачен, сессии нет. Зашел на свитч — линк на порту есть, ошибки не копятся, но маки не приходят. Перезагрузка порта не помогла.

Когда я наконец пришел домой после смены, было похоже что Микротик завис. Лампочки горели, но DHCP он не раздавал, по MAC к нему подключиться тоже не удалось. После его перезагрузки связь восстановилась. Подозреваю что причиной стала высокая и длительная нагрузка на CPU, но выяснил я это уже позже. Как оказалось, при скачивании торрента на компьютере со скоростью 25-30 МБ/сек, нагрузка на CPU Микротика держится в районе 90-100%. А перед уходом на работу я как раз поставил скачиваться 5 сезонов сериала.

Как же я решил проблему высокой нагрузки на CPU MikroTik?

Источник

ИТ База знаний

Курс по Asterisk

Полезно

— Узнать IP — адрес компьютера в интернете

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Калькулятор инсталляции IP — АТС Asterisk

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

Высокая загрузка процессора Mikrotik. Что делать?

4 минуты чтения

Сетевое оборудование вендора Mikrotik является весьма любопытным и привлекательным продуктом в сегменте SOHO (Small office/home office). Соотношение цены, качества, функционала и стабильности обеспечивает все большее распространение небольших белых коробочек в офисах небольших компаний.

Онлайн курс по Кибербезопасности

Изучи хакерский майндсет и научись защищать свою инфраструктуру! Самые важные и актуальные знания, которые помогут не только войти в ИБ, но и понять реальное положение дел в индустрии

Но спустя какое-то время беззаботного пользования, пользователи начинают жаловаться. Администратор, открыв Winbox, переходит в раздел SystemResources и видит, что загрузка процессора 100%:

Не стоит волноваться. У нас есть решение. Все настройки и «траблшутинг» будем осуществлять с помощью Winbox.

Настройка Firewall в Mikrotik

Первым делом давайте проверим службу, которая больше всего «отъедает» ресурсов процессор. Для этого, перейдем в раздел ToolsProfile:

Как видно из скриншота, львиную долю ресурсов нашего процессора занимает служба DNS. Давайте посмотрим, что происходит на уровне обмена пакетами на основном интерфейс ether1. Для этого воспользуемся утилитой ToolsTorch:

Читайте также:  Mikrotik routerboard 750 wifi

Мы видим большое количество пакетов с различных IP – адресов на 53 порт. Наш Mikrotik отвечает на каждый из таких запросов, тем самым, нерационально используя ресурсы процессора и повышая температуру.

Эту проблему надо решать. Судя по снятому дампу, пакеты приходят с частотой 10-20 секунд с одного IP – адреса. Добавим в наш Firewall два правила:

  1. Все IP – адреса, пакеты с которых приходят на 53 порт нашего Микротика будут помещаться в специальный лист с названием dns spoofing на 1 час.
  2. Каждый IP – адрес, с которого будет поступать запрос на 53 порт будет проверяться на предмет нахождения в списке dns spoofing . Если он там есть, мы будем считать, что это DNS – спуфинг с частотой реже чем раз в час и будем дропать данный пакет.

Переходим к настройке. В разделе IPFirewallFilter Rules создаем первое правило нажав на значок «+». Во кладке General указываем следующие параметры:

  • Chain = input — обрабатываем приходящие пакеты
  • Protocol = UDP — нас интересуют пакеты, у которых в качестве транспорта используется UDP
  • Dst. Port = 53 — портом назначения должен быть 53 порт, то есть DNS служба
  • In. Interface = ether1 — проверка подвергаются все пакеты, которые приходят на интерфейс ether1, который смотрит в публичную сеть.

Переходим во вкладку Action:

  • Action = add src to address list — в качестве действия, мы будем добавлять IP – адрес источника в специальный лист
  • Address List = dns spoofing — указываем имя листа, в который добавляем IP
  • Timeout = 01:00:00 — добавляем на 1 час

Нажимаем Apply и OK. Настроим второе правило, так же нажав на «+»:

Как видно, настройки во вкладке General в данной вкладке идентичны первому правилу. Нажимаем на вкладку Advanced:

  • Src. Address List= dns spoofing — указываем Микротику, производить проверку приходящего пакета на предмет нахождения в указанном листе

Переходим во вкладку Action:

  • Action = drop — если IP – адрес пакета есть в указанном списке, то дропаем этот пакет.

После того, как оба правила стали активны переходи во вкладку IPFirewallAddress Lists:

Как видно, адреса стали добавляться в список на 1 час. Теперь давайте проверим загрузку процессора:

Теперь загрузка процессора в пределах нормы. Проблема решена.

Онлайн курс по Кибербезопасности

Изучи хакерский майндсет и научись защищать свою инфраструктуру! Самые важные и актуальные знания, которые помогут не только войти в ИБ, но и понять реальное положение дел в индустрии

Источник

Mikrotik spi грузит процессор что это

Thu Apr 12, 2018 11:25 am

RB941 is running on high CPU Load which in turn is causing high internet latency
The /system profile shows Management at 40% and SPI at 30% which are causing most of the load.

I have even disabled SNMP and Traffic Flow but that does not seem to help. Kindly advise what could be causing this to happen and how to resolve

Kind Regards,
Cedric

Re: RB941 running on high CPU Load — SPI and Management

Thu Apr 12, 2018 2:25 pm

30% on SPI may be normal depending on your traffic and on whether you use fasttracking or not. What surprises me is 40% on management.

What is connected at the private (LAN) side of your Mikrotik, what kind of traffic do you expect (live videos, just web pages), and what does

Re: RB941 running on high CPU Load — SPI and Management

Thu Apr 12, 2018 3:18 pm

Please find below /export hide-sensitive. There is DVR traffic and web/email users, also port forwarding for RDP and DVR

Re: RB941 running on high CPU Load — SPI and Management [SOLVED]

Thu Apr 12, 2018 4:27 pm

I can also see that you haven’t restricted access to http (www) management interface using any other means than the firewall filter.

Together with software version 6.34.1, I would be afraid that your machine has been infected by malware exploiting the vulnerability of http server as described here and that the load could be coming from the activity of this malware. So the first thing to do would be to upgrade to 6.40.7 if you want to avoid 6.41.x for the moment. Then I would check the

Читайте также:  Настройка адгуард на роутере

Источник

Mikrotik spi грузит процессор что это

Tue Oct 22, 2013 10:33 am

Re: What is Tools->Profile->SPI usage??

Tue Oct 22, 2013 12:45 pm

Re: What is Tools->Profile->SPI usage??

Mon Nov 04, 2013 8:54 am

Re: What is Tools->Profile->SPI usage??

Mon Nov 04, 2013 3:24 pm

Re: What is Tools->Profile->SPI usage??

Mon Nov 04, 2013 10:13 pm

Re: What is Tools->Profile->SPI usage??

Tue Nov 05, 2013 9:31 am

Re: What is Tools->Profile->SPI usage??

Tue Nov 05, 2013 6:38 pm

Re: What is Tools->Profile->SPI usage??

Tue Nov 05, 2013 7:31 pm

Re: What is Tools->Profile->SPI usage??

Wed Nov 06, 2013 9:20 am

RB750, 450 and 493 do not have possibility for any external memory, not even USB.

Yesterday I was having problems again with the 493 .. I decide to disable the local cache from Web Proxy because again SPI and Unclassified takes 20-30 % of CPU and machine was slow responsive.

Strange thing is that WAN interface showed only a traffic of 15-20 mbps. so it seems the CPU of this machines was designed with NO CACHE in mind.

Re: What is Tools->Profile->SPI usage??

Wed Nov 06, 2013 9:56 am

Re: What is Tools->Profile->SPI usage??

Wed Nov 06, 2013 1:38 pm

I perfectly agree with you. this equipment’s are installed in QUITE EXTREME REMOTE areas far from civilized world replacing x86 computers before. (because of the space and low power consumption requirements).

We will focus setting cache on none and using Proxy Cluster cache.

Re: What is Tools->Profile->SPI usage??

Wed Jan 14, 2015 12:05 pm

Re: What is Tools->Profile->SPI usage??

Fri May 12, 2017 6:28 pm

We will contribute to keep you updated!

Re: What is Tools->Profile->SPI usage??

Fri Aug 04, 2017 10:22 pm

SPI stands for Serial Peripheral Interface. It is one of the buses on the router that is used to talk to certain components, like the LCD panel as previously stated. Anyone that has ever message with an Arduino should be familiar with this type of bus.
https://en.wikipedia.org/wiki/Serial_Pe . erface_Bus

I was seeing 30% CPU utilization on a router today and all of the usage was on SPI. I went into the LCD configuration and changed it to «Read Only Mode» and the usage dropped down to 2-4% for SPI in the profile tool and now the router is sitting at

8% CPU utilization with SPI only using 2-4% periodically, which makes sense because if that is the router updating the LCD screen and I am running the «stats slideshow» for the WAN interface on the LCD, so I would expect some CPU utilization there as it updates the graphs.

Re: What is Tools->Profile->SPI usage??

Fri Aug 04, 2017 10:33 pm

Re: What is Tools->Profile->SPI usage??

Sat Aug 05, 2017 3:53 am

I would think that would fall under the category of firewall as conntrack is a component of iptables.

Unfortunately I cant find any instance of where anyone from Mikrotik has officially documented what spi in the profile tool actually means. My comments are based purely on observed behavior of the platform.

Re: What is Tools->Profile->SPI usage??

Sat Aug 05, 2017 2:22 pm

Re: What is Tools->Profile->SPI usage??

Mon Jul 22, 2019 9:45 pm

SPI stands for Serial Peripheral Interface. It is one of the buses on the router that is used to talk to certain components, like the LCD panel as previously stated. Anyone that has ever message with an Arduino should be familiar with this type of bus.
https://en.wikipedia.org/wiki/Serial_Pe . erface_Bus

I was seeing 30% CPU utilization on a router today and all of the usage was on SPI. I went into the LCD configuration and changed it to «Read Only Mode» and the usage dropped down to 2-4% for SPI in the profile tool and now the router is sitting at

Читайте также:  Можно ли перепрошить ростелекомовский роутер

8% CPU utilization with SPI only using 2-4% periodically, which makes sense because if that is the router updating the LCD screen and I am running the «stats slideshow» for the WAN interface on the LCD, so I would expect some CPU utilization there as it updates the graphs.

Источник

Mikrotik spi грузит процессор что это

Thu Jul 04, 2019 12:41 pm

So 100% load cpu with 65% networking.

i think someone ddos me.
I think they smth download form my server(because in interface sfp 1 tx 400 kbit, but rx much hier (about 5 mbts,im not sure i forgot)), i dont know how block download (and not sure i need block this or idk)

Re: High cpu networking

Thu Jul 04, 2019 1:50 pm

Re: High cpu networking

Thu Jul 04, 2019 3:40 pm

which ports is the traffic going to?

Also notice that you have a similar return traffic as well?
open dns server or some other traffic bounce?

What is your firewall config (/export hide-sensitive)?

Re: High cpu networking

Thu Jul 04, 2019 7:28 pm

which ports is the traffic going to?

Also notice that you have a similar return traffic as well?
open dns server or some other traffic bounce?

What is your firewall config (/export hide-sensitive)?

Thanks for attention

/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no mode=ap-bridge \
ssid=kpst18630
set [ find default-name=wlan2 ] ssid=kpst18630 wireless-protocol=802.11
/interface list
add name=internet
add name=Local
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=»» \
mode=dynamic-keys supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp_pool0 ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=wlan2
/ip settings
set tcp-syncookies=yes
/interface list member
add interface=sfp1 list=internet
add interface=ether1 list=Local
add interface=ether2 list=Local
add interface=ether3 list=Local
add interface=ether4 list=Local
add interface=ether5 list=Local
add interface=wlan1 list=Local
add interface=wlan2 list=Local
/ip address
add address=192.168.88.1/24 interface=bridge1 network=192.168.88.0
/ip arp
add address=192.168.88.253 interface=bridge1 mac-address=18:31:BF:BD:2E:7E
add address=192.168.88.254 interface=bridge1 mac-address=18:31:BF:DF:8C:C2
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=sfp1
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip firewall address-list
add address=192.168.88.0/24 list=»Protect DDOS attack»
/ip firewall filter
add action=accept chain=forward connection-state=established,related
add action=drop chain=forward connection-state=invalid
add action=accept chain=input connection-state=established,related
add action=drop chain=input connection-state=invalid
add action=add-src-to-address-list address-list=»Protect DDOS attack» \
address-list-timeout=1d chain=input connection-limit=100,32 \
in-interface-list=all protocol=tcp
add action=tarpit chain=input connection-limit=3,32 protocol=tcp \
src-address-list=»Protect DDOS attack»
add action=jump chain=forward connection-state=new jump-target=SYN-Protect \
protocol=tcp tcp-flags=syn
add action=jump chain=input connection-state=new in-interface-list=internet \
jump-target=SYN-Protect protocol=tcp tcp-flags=syn
add action=return chain=SYN-Protect connection-state=new limit=50,5:packet \
protocol=tcp tcp-flags=syn
add action=drop chain=SYN-Protect connection-state=new protocol=tcp tcp-flags=\
syn
/ip firewall nat
add action=masquerade chain=srcnat out-interface=sfp1
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=10000 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.253 to-ports=10000
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=80 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.253 to-ports=80
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=34197 \
in-interface=sfp1 protocol=udp to-addresses=192.168.88.254 to-ports=34197
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=34198 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.252 to-ports=34198
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=8303 \
in-interface=sfp1 protocol=udp to-addresses=192.168.88.252 to-ports=8303
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=4000 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.252 to-ports=4000
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=8304 \
in-interface=sfp1 protocol=udp to-addresses=192.168.88.254 to-ports=8304
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=1000-8302 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.253 to-ports=\
1000-8302
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=10999-16000 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.253 to-ports=\
10999-16000
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=9014 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.246 to-ports=9014
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=2106 \
in-interface=sfp1 protocol=tcp to-addresses=192.168.88.246 to-ports=2106
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=7777 \
in-interface=sfp1 protocol=udp to-addresses=192.168.88.246 to-ports=7777
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=80 protocol=\
tcp src-address=192.168.88.0/24 to-addresses=192.168.88.253 to-ports=80
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=10999-16000 \
protocol=tcp src-address=192.168.88.0/24 to-addresses=192.168.88.253 \
to-ports=10999-16000
add action=dst-nat chain=dstnat dst-address=MyIp dst-port=1000-8302 \
protocol=tcp src-address=192.168.88.0/24 to-addresses=192.168.88.253 \
to-ports=1000-8302
add action=masquerade chain=srcnat dst-address=192.168.88.253 dst-port=80 \
protocol=tcp src-address=192.168.88.0/24 to-ports=80
add action=masquerade chain=srcnat dst-address=192.168.88.253 dst-port=\
1000-8302 protocol=tcp src-address=192.168.88.0/24 to-ports=1000-8302
add action=masquerade chain=srcnat dst-address=192.168.88.253 dst-port=\
10999-16000 protocol=tcp src-address=192.168.88.0/24 to-ports=10999-16000
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Asia/Krasnoyarsk

Can someone help in skype my login on screen
I cant use my innternet cus this «bad feels»

Источник

Adblock
detector