Mikrotik агрегация двух провайдеров

Настройка агрегации каналов(bonding) на Mikrotik

Bonding- объединение нескольких линков с целью увеличения пропускной способности канала, а так же с целью резервирования. Например, объединить 2 WAN порта по 100 Мбит/c в один bonding канал и получить скорость 200 Мбит/c.

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Настройка bonding интерфейса

Подключаемся через winbox к маршрутизатору Mikrotik. Заходим в меню interfaces и открываем вкладку bonding. Нажимаем «+», добавить.

В поле Name вписываем название создаваемого канала. Переходим на вкладку «Bonding»

Slaves –Выбираем интерфейсы которые мы хотим объединить в бондинг. Если нужно добавить больше портов, нажмите на треугольник с левой стороны.

Mode – режим работы принимает следующие значения:

Balance rr – балансировка round-robin, пакеты отправляются по очереди с первого порта и до последнего по кругу, при выходе одного из интерфейсов из строя, оставшиеся продолжают работать, таким образом обеспечивается отказоустойчивость, если порты подключены к разным коммутаторам требуется их настройка.

802.3ad – агрегирование интерфейсов, создается группа интерфейсов, при приеме и передаче используются все линки, таким образом, увеличивается пропускная способность канала. Требуется поддержка коммутатора и его дополнительная настройка.

Active backup – активный-резервный, при такой политике один линк активный и пакеты отправляются через него, остальные в это время не работают, при выходе из строя активного интерфейса, в работу вступает один из резервных. При таком режиме дополнительной настройки от коммутатора не требуется.

Balance tlb — Политика адаптивной балансировки нагрузки передачи. Исходящий трафик распределяется в зависимости от загруженности каждого порта (определяется скоростью загрузки). Не требует дополнительной настройки на коммутаторе. Входящий трафик приходит на активный линк. Если он выходит из строя, то другой порт берёт себе MAC адрес вышедшего из строя. Недостатком этого режима является то, что поддерживается только мониторинг каналов mii

balance-alb — политика в основном такой же, как balance-tlb, но входящий трафик также сбалансирован.

balance-xor — Этот режим уравновешивает исходящий трафик через активные линки на основе хешированной информации заголовка протокола и принимает входящий трафик от любого активного линка. Режим очень похож на LACP, за исключением того, что он не стандартизован и работает с хеш-политикой layer-3-and-4.

broadcast — Все пакеты передаются на все линки. Политика обеспечивает отказоустойчивость. Это политика не обеспечивает балансировку нагрузки.
Остальные настройки оставляем как есть , если только не выбран политика Active backup, если выбрали этот режим то в поле Primary выберите активный интерфейс.
После выбора нужного режима работы переходим к следующему шагу

Читайте также:  Ssl error no cypher overlap zyxel

Настройка ip адреса на интерфейсе bonding

Следующим шагом нам необходимо настроить ip адрес на созданном интерфейсе. Переходим в меню ip-addresses и жмем кнопку добавить.

В открывшемся окне в поле Address прописываем наш ip адрес, а в поле Interfaces выбираем созданный канал bonding1, нажимаем кнопку «ОК». На этом настройка агрегации каналов на Микротике закончена.

Далее нужно настроить DHCP сервер и NAT.

Обучающий курс по настройке MikroTik

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Источник

Kurgan-Telecom Ru | Информационные технологии

User login

Languages

Recent blog posts

Active forum topics

Habr.com

Linux.org.ru

Настройка агрегации каналов(bonding) на Mikrotik

Bonding- объединение нескольких линков с целью увеличения пропускной способности канала, а так же с целью резервирования. Например, объединить 2 WAN порта по 100 Мбит/c в один bonding канал и получить скорость 200 Мбит/c.

LACP (англ. link aggregation control protocol) — открытый стандартный протокол агрегирования каналов, описанный в документах IEEE 802.3ad и IEEE 802.1aq. Многие производители для своих продуктов используют не стандарт, а патентованные или закрытые технологии, например, Cisco применяет технологию EtherChannel (разработанную в начале 1990-х годов компанией Kalpana), а также нестандартный протокол PAgP.

Главное преимущество агрегирования каналов в том, что потенциально повышается полоса пропускания: в идеальных условиях полоса может достичь суммы полос пропускания объединённых каналов. Другое преимущество — «горячее» резервирование линий связи: в случае отказа одного из агрегируемых каналов трафик без прерывания сервиса посылается через оставшиеся, а после восстановления отказавшего канала он автоматически включается в работу.

Настройка bonding интерфейса

Подключаемся через winbox к маршрутизатору Mikrotik. Заходим в меню interfaces и открываем вкладку bonding. Нажимаем «+», добавить.

В поле Name вписываем название создаваемого канала. Переходим на вкладку «Bonding»

Slaves –Выбираем интерфейсы которые мы хотим объединить в бондинг. Если нужно добавить больше портов, нажмите на треугольник с левой стороны.

Mode – режим работы принимает следующие значения:

Balance rr – балансировка round-robin, пакеты отправляются по очереди с первого порта и до последнего по кругу, при выходе одного из интерфейсов из строя, оставшиеся продолжают работать, таким образом обеспечивается отказоустойчивость, если порты подключены к разным коммутаторам требуется их настройка.

802.3ad – агрегирование интерфейсов, создается группа интерфейсов, при приеме и передаче используются все линки, таким образом, увеличивается пропускная способность канала. Требуется поддержка коммутатора и его дополнительная настройка.

Active backup – активный-резервный, при такой политике один линк активный и пакеты отправляются через него, остальные в это время не работают, при выходе из строя активного интерфейса, в работу вступает один из резервных. При таком режиме дополнительной настройки от коммутатора не требуется.

Читайте также:  Роутеры ростелеком d link dir 300

Balance tlb — Политика адаптивной балансировки нагрузки передачи. Исходящий трафик распределяется в зависимости от загруженности каждого порта (определяется скоростью загрузки). Не требует дополнительной настройки на коммутаторе. Входящий трафик приходит на активный линк. Если он выходит из строя, то другой порт берёт себе MAC адрес вышедшего из строя. Недостатком этого режима является то, что поддерживается только мониторинг каналов mii

balance-alb — политика в основном такой же, как balance-tlb, но входящий трафик также сбалансирован.

balance-xor — Этот режим уравновешивает исходящий трафик через активные линки на основе хешированной информации заголовка протокола и принимает входящий трафик от любого активного линка. Режим очень похож на LACP, за исключением того, что он не стандартизован и работает с хеш-политикой layer-3-and-4.

broadcast — Все пакеты передаются на все линки. Политика обеспечивает отказоустойчивость. Это политика не обеспечивает балансировку нагрузки.
Остальные настройки оставляем как есть , если только не выбран политика Active backup, если выбрали этот режим то в поле Primary выберите активный интерфейс.
После выбора нужного режима работы, переходим к следующему шагу

Настройка ip адреса на интерфейсе bonding

Следующим шагом нам необходимо настроить ip адрес на созданном интерфейсе. Переходим в меню ip-addresses и жмем кнопку добавить.

В открывшемся окне в поле Address прописываем наш ip адрес, а в поле Interfaces выбираем созданный канал bonding1, нажимаем кнопку «ОК». На этом настройка агрегации каналов на Микротике закончена.

Источник

Организация локальной сети с одновременным подключением к двум интернет-провайдерам при помощи маршрутизатора MikroTik

Предположим, что у нас есть два интернет провайдера. Первый получает настройки по L2TP, для второго необходимо задать настройки статически, а нам требуется организовать безотказную работу интернет соединения. То есть, в случае отказа первого интернет провайдера маршрутизатор должен автоматически переключиться на второго (резервного) провайдера. А при восстановлении связи с первым провайдером маршрутизатор должен снова начать с ним работать.

Для решения задачи будем использовать маршрутизатор, настроенный на базе RouterOS. В данном примере MikroTik rb951ui (5-портовый). В порт №1 соответственно будет подключен провайдер «1» (ISP1) по L2TP. Во второй порт провайдер «2» (ISP2) со StaticIP. Порты №3, №4, №5 будут служить для подключения клиентов сети. IP-адреса в локальной сети будут раздаваться по DHCP. О работоспособности первого или второго канала будем судить по доступности IP-адреса. К примеру, возьмем DNS google.com, вероятность отказа которого очень мала.

Последовательность действий. Подключаем маршрутизатор к порту №3 и соответственно LAN интерфейсу ПК. Для конфигурации RouterOS будет использоваться утилита winbox. Заходим по MAC-адресу и авторизуемся. Видим интерфейс конфигурации маршрутизатора. (Рис. 1)

Рис. 1. Интерфейс конфигурации RouterOS

Первое, что мы делаем – настраиваем интерфейсы провайдера «1» и провайдера «2» Рис.2, а так же настраиваем LAN для портов 3, 4 и 5.

Рис. 2. Настройка провайдера «1» и провайдера «2»

В данном случае Интерфейс-1 принадлежит провайдеру «1» (ISP1 – имя для удобства) Интерфейс-2 принадлежит провайдеру «2» (ISP2). Для организации LAN переходим в пункт меню «Bridge» и добавляем интерфейс c именем LAN. (Рис.3).

Читайте также:  Кабель для роутера ростелекома

Рис. 3. Организация LAN

Указывает порты, которые будут относиться к внутренней сети (Рис. 4)

Рис. 4. Добавление портов в LAN

Теперь необходимо добавить IP-адреса провайдеров, а так же указать IP-адрес шлюза нашей локальной сети (Рис. 5).

Описание: Первое, что мы делаем, добавляем шлюз локальной сети (цифры 4, 5). Интерфейс указываем LAN. Второе – добавляем статический адрес второго провайдера (цифры 6, 7)

Рис. 5. Добавление адресов для интерфейсов

Так как организация подключения с первым провайдером осуществляется по L2TP необходимо добавить L2TP-клиента (Рис. 6)

Замечание: Добавляем L2TP-client (Цифра 2). Указываем соответствующие параметры во вкладке Dial-out, а именно адрес сервера, логин и пароль которые выданы первым провайдером (цифры 4, 5 и 6).

Рис. 6. Добавление L2TP-клиента

После добавления клиента во вкладке status получим соединение. (Рис. 7)

Рис. 7. Статус L2TP-соединения

Теперь займемся организацией DHCP-сервера для раздачи адресов нашим клиентам внутренней сети. Первое что сделаем, создадим pool выдаваемых адресов (Рис. 8), а затем настроим сам DHCP-сервер. (Рис 9).

Рис. 8. Создание pool’а выдаваемых адресов

Рис. 9. Добавление и настройка DHCP-сервера

Описание DHCP-сервера: Добавляем сервер с именем (server1) к интерфейсу внутренней сети LAN c пулом адресов который создавали ранее. В network указываем, какие параметры передавать серверу клиентам.

Теперь нам необходимо добавить статические маршруты, так как всё взаимодействие между сетями осуществляется в соответствии с таблицей маршрутизации. Ее управление в RouterOS осуществляется в меню «Routes». Адресация с локальной сетью и с внутренними сетями провайдеров была добавлена динамически. Осталось добавить маршруты в интернет (на адрес 0.0.0.0/0) через шлюзы провайдеров. (Рис. 10).

Рис. 10. Добавление статических маршрутов

Далее, необходимо организовать переключение каналов в случае недоступности 1 канала. В ОС роутера есть встроенная утилита «Netwatch», которая позволяет отслеживать состояние хостов в сети посредством отправки ICMP-запросов (ping) и выполнять какие-либо действия на основе их доступности. Мы будем отслеживать IP-адрес 8.8.4.4 через первый канал, и в случае его недоступности переключать маршруты на работу по второму.

Создаем новый «Netwatch host», в графе «Host» указываем отслеживаемый IP-адрес, а в «Interval» — частоту осуществляемых проверок. (Рис. 11).

Рис. 11. Настройка переключения каналов

И в заключение, в закладке Up (цифра 5) необходимо прописать следующее правило:

#включаем маршрут с комментарием «ISP1» (основной канал)
/ip route set [find comment=«ISP1»] disabled=no
#отключаем маршрут с комментарием «ISP2»(резервный канал)
/ip route set [find comment=«ISP2»] disabled=yes
Во вкладке Down прописываем следующее правило:
#отключаем маршрут с комментарием «ISP1» (резервный канал)
/ip route set [find comment=«ISP1»] disabled=yes
#включаем маршрут с комментарием «ISP2» (основной канал)
/ip route set [find comment=«ISP2»] disabled=no

Настройка правил для проходящего трафика

Используя встроенный файервол можно управлять абсолютно всем трафиком, нам необходимо запретить пинг на ISP2. Для это в окне терминала пропишем следующее:
#одобряем использование протокола icmp
ip firewall filter add chain=input comment=«Permit icmp»

#ограничиваем ping 8.8.4.4 через ISP2
ip firewall filter add action=drop chain=output comment=«Deny 8.8.4.4 to reserved internet-channel» dst-address=8.8.4.4 out-interface=«ether2 — internet II (reserve)» protocol=«icmp»

Материал является вводным и предназначен для знакомства с вопросом управления сетью с двумя провайдерами.

Источник