Два провайдера на одном маршрутизаторе

Как подключиться к двум Интернет-провайдерам, чтобы был резервный выход в сеть (а то подключение к сети иногда рвется, а работать приходиться дома)

У меня падает периодически интернет (а работаю сейчас часто из дома и это реально проблема). По этой причине хочу провести второй кабель от другого провайдера, чтобы был запасной вариант (лучше переплатить 600 рублей, зато спокойно работать).

Не подскажите, как все попроще настроить, чтобы «если-что» включался резервный канал: в случае выхода из строя основного — работал второй сам, без моих долгих действий. Можно так?

В принципе, такое организовать можно даже своими силами (еще проще: попросить монтажников, которые вам будут проводить сеть, — всё настроить 👌).

Разве только могут быть нюансы с разными особенностями у отличных Интернет-провайдеров. (для упрощения, в заметке ниже я приведу в первом способе тот случай, когда у вас уже в квартиру проведено 2 Ethernet-кабеля от разных провайдеров).

И да, на мой взгляд, для домашних нужд — есть более простой вариант решения вопроса. (см. 2-й способ внизу статьи. ).

Варианты создания резервного канала выхода в Интернет

Способ 1: настройка роутера в режиме Multi-WAN

📌 Ремарка 1 : для полной автоматизации по выбору работающего подключения сразу среди двух Ethernet-кабелей от разных провайдеров — нужен спец. Wi-Fi роутер с поддержкой режима «Multi-WAN» ( прим. : я все же исхожу из домашних условий, и что Wi-Fi нужен!).

Я бы для решения такой задачи порекомендовал присмотреться к роутерам от ZyXel и TP-link (они легко настраиваются) . Есть весьма достойные устройства от Microtic, но для начинающих они сложны в настройке.

📌 Ремарка 2 : часто проблемы с доступом в Интернет возникают из-за отключения электричества . И в этом случае, если провайдеры сэкономили на оборудовании — то доступ к сети может пропасть сразу у нескольких ваших подключений (этот момент, конечно, можно уточнить у провайдера при заключении договора на оказание услуг связи. ).

В любом случае, рекомендуется и ПК, и роутер (к которому будет подключены кабели от Интернет-провайдеров) подключить к ИБП.

1) В своем примере ниже я взял типовой роутер от ZyXel Keenetic (обратите внимание, что Ethernet-кабель от основного Интернет-провайдера подключается в гнездо WAN (обычно, оно синее), а резервный второй Ethernet-кабель — в гнездо LAN-1 (обычно, оно желтое).

В общем-то, сам процесс соединения проводов — стандартный, как и при обычном подключении.

Смотрим характеристики роутера

2) Далее нужно настроить подключение к Интернет для основного канала (WAN-порт, в прошивке Keenetic он помечен синим цветом с аббревиатурой «0»). См. скриншот ниже 👇 (никаких особых настроек тут не требуется, просто задаются параметры как при настройке обычного подключения).

Шаг 1 — проверяем, чтобы подключение к Интернет было установлено!

3) После требуется добавить еще один интерфейс для порта LAN-1 (куда был подключен резервный Ethernet-кабель от второго дополнительного провайдера), и настроить подкл. к Интернет.

Обратите внимание, что в разделе «Подключения» необходимо для основного подключения выставить более высокий приоритет.

Шаг 2 — настройка второго подключения к Интернет

4) Затем необходимо задать проверку доступности доступа в Интернет — рекомендуется это сделать для основного подключения (если оно не будет работать — роутер об этом «узнает» и переключит сеть автоматически на второе подкл-е!).

Шаг 3 — проверка работоспособности подключения 1

5) В принципе, всё!

Дальше останется настроить Wi-Fi-подключения, пробросить порты (если нужно) и пр. «мелочи» под-себя.

Читайте также:  Роутер меркусис n300 настройка wifi

Теперь попробуйте проверить, как работает роутер — просто отключите от основного WAN-порта сетевой кабель! В этот момент у вас пропал доступ в Интернет?

В идеале, если все правильно настроено, роутер «почти» сразу же в авто-режиме должен переключиться на второе резервное подключение — т.е. на компьютере дальше будут продолжать открываться веб-странички. 👌

Когда восстановится норм. доступ по WAN — устройство переключится снова на основной канал связи.

Способ 2: создание точки доступа на телефоне (расшаривание мобильного интернета)

Вообще, приведенный выше вариант резервного канала (для домашних условий) мне не очень нравится по нескольким причинам:

  • во-первых , при отключении электричества в доме (районе) — очень вероятно, что оборудование провайдера тоже отключится и доступ в Интернет пропадет;
  • во-вторых , нужно проводить в квартиру второй кабель, что не всегда удобно (да и платить опять же нужно будет за 2 провайдера. );
  • в-третьих , в силу разных особенностей — не всегда просто настроить корректно работу резервного канала (по крайней мере, не всегда это можно сделать дешево. ).

📌 И в этом плане (на мой взгляд) хорошим резервным каналом может служить обычный смартфон (при наличии у вас достаточного кол-ва трафика). Он лишен выше-оговоренных недостатков, к тому же он уже есть, и за него так и так платишь. (единственный недостаток: скорость ниже и меньшее кол-во трафика, чем у проводного подключения).

Как поделиться Интернетом с телефона (для Android):

    сначала проверяем, есть ли на телефоне мобильный интернет (это можно увидеть даже 📌по значкам. 👇);

Доступ к Интернет есть

  • далее открыть его настройки ;
  • затем войти во вкладку «Подключения» и найти раздел «Мобильная точка доступа» ;
  • включить данный режим в смартфоне и задать название Wi-Fi сети и пароля;

    Мобильная точка доступа — Android 10

    затем на ноутбуке (ПК) подключиться к этой Wi-Fi сети. На все про все — потребуется 1-2 мин.

    Подключаемся к точке доступа

    Причем, этот способ хорош и тем, что при откл. электричества — очень вероятно, что сеть будет работать (а если вы пользуетесь ноутбуком — то часа на 3-4 работы этого способа должно хватить).

    Как с Android раздавать интернет на компьютер или ноутбук (по USB, Wi-Fi или Bluetooth) — https://ocomp.info/razdavat-internet-s-android.html

    PS

    Еще один сподручный вариант : если ваш сосед подключен к другому Интернет-провайдеру — можно с ним договориться и дать друг для друга доступ к Wi-Fi сети. Когда у вас «полетит» сеть — вы попробуете подключиться к нему, когда у него — он к вам. Правда, это все работает при усл., что сосед адекватен. 😉

    Кстати , также можно прикупить USB-модем — это во многих случаях выходит дешевле, чем второе проводное подключение и оборудование для его подключения.

    USB-модем МегаФон 4G+ М150-4

    На сим пока всё. За дополнения по теме — заранее благодарю!

    Источник

    Два провайдера одновременно или Dual ISP with VRF на Cisco

    Есть универсальное решение для подключения нескольких провайдеров, ip sla + track. Решение легкое для понимания и простое в управлении. Но когда дело доходит до одновременного использования двух и более каналов связи, данная технология в чистом виде не подходит.

    Хочу поделится своим опытом. На узлах с несколькими провайдерами я использую конфигурацию содержащую виртуальные роутеры – VRF. Эта конфигурация взята из моей практики и хорошо себя зарекомендовала.

    Предположим у нас есть 2 провайдера с параметрами:

    ISP1 1.1.1.1 шлюз 1.1.1.2
    ISP2 2.2.2.1 шлюз 2.2.2.2
    И локальная сеть:
    LAN 192.168.1.1/24

    Приступим к конфигурации. Для начала нужно создать эти самые виртуальные маршрутизаторы, а будет их 3. Два на провайдеров и один на локальную сеть.

    Сразу же настроим правила экспорта маршрутов, что бы не возвращается в раздел ip vrf. Логика следующая – нельзя обменивается маршрутами между VRF провайдеров (на самом деле можно, но при таких вариантах настройка усложнится). На пальцах: VRF провайдеров могут получать и отправлять маршруты только в/от VRF локальной сети. VRF локальной сети может отправлять свои маршруты и получать маршруты от любых других VRF.

    Читайте также:  Mikrotik закрыть 443 порт снаружи

    Вводим данные о сетях в наш маршрутизатор, не забываем сразу включить NAT и назначить интерфейсам нужные VRF. Один интерфейс не может принадлежать сразу нескольким VRF. Представьте себе, что вы решили сделать из одного маршрутизатора несколько, распилив его на части и в каждой части остались свои интерфейсы.

    Все, теперь у нас есть 3 маленьких, но гордых независимых маршрутизатора. Перед тем как сделать главное – прописать шлюзы провайдеров, надо настроить ip sla тест. Делается это так же, как и в стандартном решении, но с указанием VFR’а из которого предполагается проводит ip sla тест.

    Добавляем маршруты в наши виртуальные маршрутизаторы, которые отвечают за связь с провайдерами. Обратите внимание на значения метрики, на резервном канале метрика выше и далее вы поймете почему.

    В принципе этого уже достаточно, для того что бы к маршрутизатору можно было подключится из вне по публичному адресу любого из провайдеров (если, конечно, настроен SSH или telnet доступ).

    Далее приготовим NAT, все делаем практически так же, как мы привыкли настраивать в стандартном решении без VRF. Делаем access-list который запрещает транслировать локальные адреса в локальные адреса:

    Делаем карты маршрутизации для каждого провайдера:

    И включаем NAT overload (обратите внимание, что правило настраивается на виртуальный маршрутизатор vrf lan):

    Наше элегантное решение практически готово, но нужен финальный штрих, это BGP процесс который будет заниматься перераспределением маршрутов между VRF учитывая правила импорта\экспорта которые мы настроили в каждом VRF.

    Команда default-information originate позволяет передавать через bgp маршрут по умолчанию. В результате, в кандидаты на маршрут по умолчанию для vrf lan попадут два маршрута до шлюзов разных провайдеров, но с помощью bgp будет выбран тот, у которого метрика меньше. Соответственно если вдруг надо переключить NAT с одного провайдера на другой, достаточно будет поменять метрику в таблице маршрутизации одного из VRF.

    Заключение. Данная конфигурация позволяет организовать подключение к двум провайдерам связи одновременно. Конфигурация очень гибкая, используя PBR, можно разделять трафик между провайдерами, и даже в случае падения одно из них, продолжать предоставлять сервис. Особенность VRF, позволяет даже во время сложных манипуляций с конфигурацией не потерять связь с устройством (нельзя одновременно править две таблицы маршрутизации, хотя…). Конфигурация легко расширяется и позволяет без заморочек добавить новых провайдеров.

    Из недостатков, хочу отметить необходимость почти в любую команду вставлять дополнительный текст vrf . Так просмотр таблицы маршрутизации виртуального роутера локальной сети вызывается командой:

    Пинг из vrf первого провайдера:

    Спасибо за внимание. Подготовлено на роутере Cisco 881 IOS version 15.5

    Источник

    Организация локальной сети с одновременным подключением к двум интернет-провайдерам при помощи маршрутизатора MikroTik

    Предположим, что у нас есть два интернет провайдера. Первый получает настройки по L2TP, для второго необходимо задать настройки статически, а нам требуется организовать безотказную работу интернет соединения. То есть, в случае отказа первого интернет провайдера маршрутизатор должен автоматически переключиться на второго (резервного) провайдера. А при восстановлении связи с первым провайдером маршрутизатор должен снова начать с ним работать.

    Для решения задачи будем использовать маршрутизатор, настроенный на базе RouterOS. В данном примере MikroTik rb951ui (5-портовый). В порт №1 соответственно будет подключен провайдер «1» (ISP1) по L2TP. Во второй порт провайдер «2» (ISP2) со StaticIP. Порты №3, №4, №5 будут служить для подключения клиентов сети. IP-адреса в локальной сети будут раздаваться по DHCP. О работоспособности первого или второго канала будем судить по доступности IP-адреса. К примеру, возьмем DNS google.com, вероятность отказа которого очень мала.

    Читайте также:  Забыла пароль от вай фай роутера мгтс

    Последовательность действий. Подключаем маршрутизатор к порту №3 и соответственно LAN интерфейсу ПК. Для конфигурации RouterOS будет использоваться утилита winbox. Заходим по MAC-адресу и авторизуемся. Видим интерфейс конфигурации маршрутизатора. (Рис. 1)

    Рис. 1. Интерфейс конфигурации RouterOS

    Первое, что мы делаем – настраиваем интерфейсы провайдера «1» и провайдера «2» Рис.2, а так же настраиваем LAN для портов 3, 4 и 5.

    Рис. 2. Настройка провайдера «1» и провайдера «2»

    В данном случае Интерфейс-1 принадлежит провайдеру «1» (ISP1 – имя для удобства) Интерфейс-2 принадлежит провайдеру «2» (ISP2). Для организации LAN переходим в пункт меню «Bridge» и добавляем интерфейс c именем LAN. (Рис.3).

    Рис. 3. Организация LAN

    Указывает порты, которые будут относиться к внутренней сети (Рис. 4)

    Рис. 4. Добавление портов в LAN

    Теперь необходимо добавить IP-адреса провайдеров, а так же указать IP-адрес шлюза нашей локальной сети (Рис. 5).

    Описание: Первое, что мы делаем, добавляем шлюз локальной сети (цифры 4, 5). Интерфейс указываем LAN. Второе – добавляем статический адрес второго провайдера (цифры 6, 7)

    Рис. 5. Добавление адресов для интерфейсов

    Так как организация подключения с первым провайдером осуществляется по L2TP необходимо добавить L2TP-клиента (Рис. 6)

    Замечание: Добавляем L2TP-client (Цифра 2). Указываем соответствующие параметры во вкладке Dial-out, а именно адрес сервера, логин и пароль которые выданы первым провайдером (цифры 4, 5 и 6).

    Рис. 6. Добавление L2TP-клиента

    После добавления клиента во вкладке status получим соединение. (Рис. 7)

    Рис. 7. Статус L2TP-соединения

    Теперь займемся организацией DHCP-сервера для раздачи адресов нашим клиентам внутренней сети. Первое что сделаем, создадим pool выдаваемых адресов (Рис. 8), а затем настроим сам DHCP-сервер. (Рис 9).

    Рис. 8. Создание pool’а выдаваемых адресов

    Рис. 9. Добавление и настройка DHCP-сервера

    Описание DHCP-сервера: Добавляем сервер с именем (server1) к интерфейсу внутренней сети LAN c пулом адресов который создавали ранее. В network указываем, какие параметры передавать серверу клиентам.

    Теперь нам необходимо добавить статические маршруты, так как всё взаимодействие между сетями осуществляется в соответствии с таблицей маршрутизации. Ее управление в RouterOS осуществляется в меню «Routes». Адресация с локальной сетью и с внутренними сетями провайдеров была добавлена динамически. Осталось добавить маршруты в интернет (на адрес 0.0.0.0/0) через шлюзы провайдеров. (Рис. 10).

    Рис. 10. Добавление статических маршрутов

    Далее, необходимо организовать переключение каналов в случае недоступности 1 канала. В ОС роутера есть встроенная утилита «Netwatch», которая позволяет отслеживать состояние хостов в сети посредством отправки ICMP-запросов (ping) и выполнять какие-либо действия на основе их доступности. Мы будем отслеживать IP-адрес 8.8.4.4 через первый канал, и в случае его недоступности переключать маршруты на работу по второму.

    Создаем новый «Netwatch host», в графе «Host» указываем отслеживаемый IP-адрес, а в «Interval» — частоту осуществляемых проверок. (Рис. 11).

    Рис. 11. Настройка переключения каналов

    И в заключение, в закладке Up (цифра 5) необходимо прописать следующее правило:

    #включаем маршрут с комментарием «ISP1» (основной канал)
    /ip route set [find comment=«ISP1»] disabled=no
    #отключаем маршрут с комментарием «ISP2»(резервный канал)
    /ip route set [find comment=«ISP2»] disabled=yes
    Во вкладке Down прописываем следующее правило:
    #отключаем маршрут с комментарием «ISP1» (резервный канал)
    /ip route set [find comment=«ISP1»] disabled=yes
    #включаем маршрут с комментарием «ISP2» (основной канал)
    /ip route set [find comment=«ISP2»] disabled=no

    Настройка правил для проходящего трафика

    Используя встроенный файервол можно управлять абсолютно всем трафиком, нам необходимо запретить пинг на ISP2. Для это в окне терминала пропишем следующее:
    #одобряем использование протокола icmp
    ip firewall filter add chain=input comment=«Permit icmp»

    #ограничиваем ping 8.8.4.4 через ISP2
    ip firewall filter add action=drop chain=output comment=«Deny 8.8.4.4 to reserved internet-channel» dst-address=8.8.4.4 out-interface=«ether2 — internet II (reserve)» protocol=«icmp»

    Материал является вводным и предназначен для знакомства с вопросом управления сетью с двумя провайдерами.

    Источник

  • Adblock
    detector