Current cell id mikrotik

Current cell id mikrotik

Fri Apr 21, 2017 6:52 am

Does anyone know how to show the Physical Cell ID (PCI) the the device is connected to.

I can do it on other hardware (e.g. Huawei B315 and iPhone 6 — screenshot from my iPhone below).

Re: SXT LTE — Show Physical Cell ID (PCI)

Fri Apr 21, 2017 4:27 pm

You can find this info on the quickset menu of sxt LTE or by the » /interface lte>info 0 «command on terminal

Re: SXT LTE — Show Physical Cell ID (PCI)

Sat Apr 22, 2017 3:49 am

Unfortunately that command (or doing the equivalent via the GUI) don’t expose the PCI.

The PCI is a number between 0 & 503.

I can expose it via my iPhone and despite being connected to the same cell the PCI (130) isn’t showing up anywhere on the SXT LTE.

Re: SXT LTE — Show Physical Cell ID (PCI)

Tue Apr 25, 2017 2:14 pm

You should post your config concerning the LTE part of the config then maybe we can move forward in finding a solution.

Please hide all critical parts of your configuration when posting.

use » /export compact » in the terminal to get the full config and copy from it everything concerning your LTE config.

also I confused the values you wanted. You can see the Current Cell ID is «2» on my screenshot below current operator.

Re: SXT LTE — Show Physical Cell ID (PCI)

Thu May 04, 2017 5:42 am

revision: chip:2.0 fw:0.1.2.3
current-operator: 530,01 (ECI 786691/ eNBI 3073)
current-cellid: 3
earfcn: 1800 (band 3, bandwidth 20Mhz, DL freq 1865.0Mhz)
imei: 356159060219486
imsi: 530011109255837
uicc: 1527016971281782133115240
rssi: -85dBm
rsrp: -115dBm
rsrq: -10dB
sinr: 9dB

The Cell ID of «3» is not the PCI.

Export of my config as requested is below.

It’s important to note that the PCI which is what I’m after (to identify the cell I’m connecting to) is different to the «Cell ID» the Mikrotik is showing.

# may/04/2017 14:28:20 by RouterOS 6.36.3
# software > #
/interface ethernet
set [ find default-name=ether1 ] mac-address= >
/interface lte
set [ find ] add-default-route=yes band=3 default-route-distance=1 ip-type=\
ipv4 ipv6-interface=none mac-address= > name=lte1 \
network-mode=lte use-peer-dns=yes
/ip neighbor discovery
set lte1 discover=no
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=ether1 name=defconf
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether1 network=\
192.168.88.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=192.168.88.1 \
gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers= >
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add action=accept chain=input comment=»defconf: accept ICMP» protocol=icmp
add action=accept chain=input comment=»defconf: accept established,related» \
connection-state=established,related
add action=accept chain=input comment=» >» dst-port=\
80,8291 protocol=tcp src-address= >
add action=drop chain=input comment=»defconf: drop all from WAN» \
in-interface=lte1
add action=fasttrack-connection chain=forward comment=»defconf: fasttrack» \
connection-state=established,related
add action=accept chain=forward comment=\
«defconf: accept established,related» connection-state=\
established,related
add action=drop chain=forward comment=»defconf: drop invalid» \
connection-state=invalid
add action=drop chain=forward comment=\
«defconf: drop all from WAN not DSTNATed» connection-nat-state=!dstnat \
connection-state=new in-interface=lte1
/ip firewall nat
add action=masquerade chain=srcnat comment=»defconf: masquerade» \
out-interface=lte1
/system clock
set time-zone-name=Pacific/Auckland
/system identity
set name=» >»
/system logging
add topics=lte
/system routerboard settings
set init-delay=0s protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether1
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1

Источник

Manual:Interface/LTE

Applies to RouterOS: v6+,v5.12+

Contents

Summary

Support for Direct-IP mode type cards only. MBIM support is available in RouterOS v7 releases and MBIM driver is loaded automatically. If modem is not recognized in RouterOS v6 — Please test it in v7 releases before asking for support in RouterOS v6.

Читайте также:  Постоянно приходится перезагружать маршрутизатор

To enable access via a PPP interface instead of a LTE Interface, change direct IP mode with /port firmware set ignore-directip-modem=yes command and a reboot. Note that using PPP emulation mode you may not get the same throughput speeds as using the LTE interface emulation type.

Warning: In RouterOS v7 ignore-direct-modem parameter is moved under /system routerboard modem menu

LTE Client

Sub-menu: /interface lte

Properties

Property Description
allow-roaming (yes | no; Default: no) Enable data roaming for connecting to other countries data-providers. Not all LTE modems support this feature. Some modems, that do not fully support this feature, will connect to the network but will not establish an IP data connection with allow-roaming set to no.
apn-profiles (string; Default: default) Which APN profile to use for this interface
band (integer list; Default: «») Frequency band used in communication LTE Bands and bandwidths
comment (string; Default: «») Descriptive name of an item
disabled (yes | no; Default: yes) Whether interface is disabled or not. By default it is disabled.
mac-address (MAC; Default: «») Media Access Control number of an interface.
modem-init (string; Default: «») Modem init string (AT command that will be executed at modem startup)
mtu (integer; Default: 1500) Maximum Transmission Unit. Max packet size that LTE interface will be able to send without packet fragmentation.
name (string; Default: «») Descriptive name of the interface.
network-mode (3g | gsm | lte; Default: 3g,gsm,lte) Select/force mode for LTE interface to operate with
operator (integer; Default: «») used to lock device to specific operator full PLMN number is used for lock consisting from MCC+MNC. PLMN codes
pin (integer; Default: «») SIM Card’s PIN code.

APN profiles

All network related settings are moved under profiles, starting from RouterOS 6.41

Sub-menu: /interface lte apn

Property Description
add-default-route (yes | no) Whether to add default route to forward all traffic over the LTE interface.
apn (string) Service Provider’s Access Point Name
authentication (pap | chap | none; Default: none) Allowed protocol to use for authentication
default-route-distance (integer; Default: 2) Sets distance value applied to auto created default route, if add-default-route is also selected. LTE route by default is with distance 2 to prefer wired routes over LTE
ip-type (ipv4 | ipv4-ipv6 | ipv6; Default: ) Requested PDN type
ipv6-interface ( ; Default: ) Interface on which to advertise IPv6 prefix
name (string; Default: ) APN profile name
number (integer; Default: ) APN profile number
passthrough-interface ( ; Default: ) Interface to passthrough IP configuration (activates passthrough)
passthrough-mac (MAC; Default: auto) If set to auto, then will learn MAC from first packet
password (string; Default: ) Password used if any of the authentication protocols are active
use-peer-dns (yes | no; Default: yes) If set to yes, uses DNS recieved from LTE interface
user (integer) Username used if any of the authentication protocols are active

Scanner

It is possible to scan LTE interfaces with /interface lte scan command

Available read only properties:

Property Description
duration (integer) Duration of scan in seconds
freeze-frame-interval (integer) time between data printout
number (integer) Interface number or name

User Info command

It is possible to send special «info» command to LTE interface with /interface lte info command.

Properties (Up to 6.40)

Property Description
user-command (string; Default: «») send a command to LTE card to extract useful information, e.g. with AT commands
user-command-only (yes | no; Default: )

User at-chat command

It is possible to send user defined «at-chat» command to LTE interface with /interface lte at-chat command.

You can also use «at-chat» function in scripts and assign command output to variable.

Quick setup example

Start with network settings —

Warning: This guide is for RouterOS versions starting from 6.41

Start with network settings — Add new connection parameters under LTE apn profile (provided by network provider):

Select newly created profile for LTE connection:

LTE interface should appear with running (R) flag:

From RouterOS=>6.41 DHCP client is added automatically. If it’s not added — add a DHCP Client to LTE Interface manually:

If required, add NAT Masquerade for LTE Interface to get internet to the local network:

Читайте также:  Программное обеспечение к маршрутизатору

After interface is added, you can use «info» command to see what parameters client acquired (parameters returned depends on LTE hardware device):

Passthrough Example

Starting from RouterOS v6.41 some LTE interfaces support LTE Passthrough feature where the IP configuration is applied directly to the client device. In this case modem firmware is responsible for the IP configuration and router is used only to configure modem settings — APN, Network Technologies and IP-Type. In this configuration the router will not get IP configuration from the modem. The LTE Passthrough modem can pass both IPv4 and IPv6 addresses if that is supported by modem. Some modems support multiple APN where you can pass the traffic from each APN to a specific router interface.

Passthrough will only work for one host. Router will automatically detect MAC address of the first received packet and use it for the Passthrough. If there are multiple hosts on the network it is possible to lock the Passthrough to a specific MAC. On the host on the network where the Passthrough is providing the IP a DHCP-Client should be enabled on that interface to. Note, that it will not be possible to connect to the LTE router via public lte ip address or from the host which is used by the passthrough. It is suggested to create additional connection from the LTE router to the host for configuration purposes. For example vlan interface between the LTE router and host.

To enable the Passthrough a new entry is required or the default entry should be changed in the ‘/interface lte apn’ menu

Warning: Passthrough is not supported by all chipsets.

To configure the Passthrough on ether1:

To configure the Passthrough on ether1 host 00:0C:42:03:06:AB:

To configure multiple APNs on ether1 and ether2:

To configure multiple APNs with the same APN for different interfaces:

Dual SIM

Note: The command for sim slot selection changes in v6.45.1 and again in v7. Some device models like SXT, have SIM slots named «a» and «b» instead of «up» and down»

For some boards with dual SIM slots connected to the same modem slot (like LtAP mini, ltAP, SXT) it is possible to alternate between these SIM slots.

Command for pre 6.45.1:

Command after 6.45.1:

Command in RouterOS v7 version:

Usage Example:

Follow this link — Dual SIM Application, to see examples of how to change SIM slot based on roaming status and in case the interface status is down with help of RouterOS scripts and scheduler.

Tips and Tricks

This paragraph contains information for additional features and usage cases.

Find device location using Cell information

On devices using R11e-LTE International version card (wAP LTE kit) some extra information is provided under info command (from 6.41rc61)

Property Description
current-operator (integer; Default: ) Contains MCC and MNC. For example: current-operator: 24701 breaks to: MCC=247 MNC=01
lac (integer; Default: ) location area code (LAC)
current-cellid (integer; Default: ) Station identification number

Values can be used to find location in databases: Cell Id Finder

Using Cell lock

It is possible to lock R11e-LTE, R11e-LTE6 and R11e-4G modems and equipped devices to exact LTE tower. LTE info command provides currently used cellular tower information:

Property Description
phy-cellid (integer; Default: ) Physical Cell Identification (PCI) of currently used cell tower.
earfcn (integer; Default: ) Absolute Radio Frequency Channel Number

Exact tower location as well as available bands and other information can be acquired from mobile carrier or by using online services:

By using those acquired variables it’s possible to send AT command to modem for locking to tower in current format:

for R11e-LTE and R11e-LTE6

To lock modem at previously used tower at-chat can be used:

For R11e-LTE all set on locks are lost after reboot or modem reset. Cell data can be also gathered from «cell-monitor».

For R11e-LTE6 cell lock works only for the primary band, this can be useful if you have multiple channels on the same band and you want to lock it to a specific earfcn. Note, that cell lock is not band-specific and for ca-band it can also use other frequency bands, unless you use band lock.

Читайте также:  Комп не подключается к роутеру ростелеком

Use cell lock to set the primary band to the 1300 earfcn and use the second channel for the ca-band:

Now it uses the earfcn: 1300 for the primary channel:

You can also set it the other way around:

Now it uses the earfcn: 1417 for the primary channel:

For R11e-LTE6 modem cell lock information will not be lost after reboot or modem reset. To remove cell lock use at-chat command:

All PLMN codes available here this variable can be also left blank

To lock modem to the cell — modem needs to be in non operating state, easiest way for R11e-4G modem is to add CellLock line to «modem-init» string:

Multiple cells can also be added by providing list instead of one tower informatin in following format:

For example to lock to two different PCIs within same band and operator:

Cell Monitor

Cell monitor allows to scan available nearby mobile network cells:

Gathered data can be used for more precise location detection or for Cell lock.

Troubleshooting

Enable LTE logging:

Check for errors in log:

search for CME error description online,

in this case: CME error 10 — SIM not inserted

Locking band on Huawei and other modems

To lock band for Huawei modems /interface lte set lte1 band=»» option can’t be used.

It is possible to use AT commands to lock to desired band manually.

To check all supported bands run at-chat command:

Example to lock to LTE band 7,

Change last part 40 to desired band specified hexadecimal value where:

All band HEX values and AT commands can be found in Huawei AT Command Interface Specification guide

Check if band is locked:

For more information check modem manufacturers AT command reference manuals.

mPCIe modems with RB9xx series devices

For mPCIe modems to work in RB9xx series devices it is required to set the USB type to mPCIe, this can be done using the following command:

In case your modem is not being recognized after a soft reboot, then you might need to add a delay before the USB port is being initialized. This can be done using the following command:

Modem firmware upgrade

Warning: Before attempting LTE modem firmware upgrade — upgrade RouterOS version to latest releases How To Upgrade RouterOS

Starting from RouterOS version 6.44beta20 it is possible to upgrade modems firmware.

Firmware update is available only as FOTA Firmware Over The Air — firmware upgrade can only be done through working mobile connection for:

Firmware update available as FOTA and as well as upgrade from file for:

Firmware updates usually includes small improvements in stability or small bug fixes that can’t be included into RouterOS.

Check currently used firmware version by running:

Check if new firmware is available:

Whole upgrade process may take up to 10 minutes, depending on mobile connection speed.

After successful upgrade issue USB power-reset, reboot device or run AT+reset command, to update modem version readout under info command:

if modem has issues connecting to cells after update, or there are any other unrelated issues — wipe old configuration with:

Avoiding tethering speed throttling

Some operators (TMobile, YOTA etc.) allows unlimited data only for device SIM card is used on, all other data coming from mobile hotspots or tethering is highly limited by volume or by throughput speed. Some sources have found out that this limitation is done by monitoring TTL (Time To Live) values from packets to determinate if limitations need to be applied (TTL is decreased by 1 for each «hop» made). RouterOS allows changing the TTL parameter for packets going from the router to allow hiding sub networks. Keep in mind that this may conflict with fair use policy.

Unlocking SIM card after multiple wrong PIN code attempts

After locking SIM card, unlock can be done through «at-chat»

Check current PIN code status:

If card is locked — unlock it by providing:

Replace PUK_code and NEW_PIN with matching values.

Источник

Adblock
detector