Агрегирование каналов на маршрутизаторе

Steinkäfer

Donnerstag, 28. Januar 2016

Cisco. Агрегирование каналов.

Общая информация об агрегировании каналов

Агрегирование каналов позволяет решить две задачи:

  • повысить пропускную способность канала
  • обеспечить резерв на случай выхода из строя одного из каналов

Большинство технологий по агрегированию позволяют объединять только параллельные каналы. То есть такие, которые начинаются на одном и том же устройстве и заканчиваются на другом.

Если рассматривать избыточные соединения между коммутаторами, то без использования специальных технологий для агрегирования каналов, передаваться данные будут только через один интерфейс, который не заблокирован STP. Такой вариант позволяет обеспечить резервирование каналов, но не дает возможности увеличить пропускную способность.

Без использования STP такое избыточное соединение создаст петлю в сети.

Технологии по агрегированию каналов позволяют использовать все интерфейсы одновременно. При этом устройства контролируют распространение широковещательных фреймов (а также multicast и unknown unicast), чтобы они не зацикливались. Для этого коммутатор, при получении широковещательного фрейма через обычный интерфейс, отправляет его в агрегированный канал только через один интерфейс. А при получении широковещательного фрейма из агрегированного канала, не отправляет его назад.

Хотя агрегирование каналов позволяет увеличить пропускную способность канала, не стоит рассчитывать на идеальную балансировку нагрузки между интерфейсами в агрегированном канале. Технологии по балансировке нагрузки в агрегированных каналах, как правило, ориентированы на балансировку по таким критериям: MAC-адресам, IP-адресам, портам отправителя или получателя (по одному критерию или их комбинации).

То есть, реальная загруженность конкретного интерфейса никак не учитывается. Поэтому один интерфейс может быть загружен больше, чем другие. Более того, при неправильном выборе метода балансировки (или если недоступны другие методы) или в некоторых топологиях, может сложиться ситуация, когда реально все данные будут передаваться, например, через один интерфейс.

Читайте также:  Усилитель сигнала сотовой связи роутер вай фай

Некоторые проприетарные разработки позволяют агрегировать каналы, которые соединяют разные устройства. Таким образом резервируется не только канал, но и само устройство. Такие технологии в общем, как правило, называются распределенным агрегированием каналов (у многих производителей есть своё название для этой технологии).

Агрегирование каналов в Cisco

Статическое агрегирование

Агрегирование с помощью LACP

Терминология и настройка

Общие правила настройки EtherChannel

Настройка EtherChannel

Так как для объединения в EtherChannel на интерфейсах должны совпадать многие настройки, проще объединять их, когда они настроены по умолчанию. А затем настраивать логический интерфейс.
Перед объединением интерфейсов лучше отключить их. Это позволит избежать блокирования интерфейсов STP (или перевода их в состояние err-disable).
Для того чтобы удалить настройки EtherChannel достаточно удалить логический интерфейс. Команды channel-group удалятся автоматически.

Создание EtherChannel для портов уровня 2 и портов уровня 3 отличается:

  • Для интерфейсов 3го уровня вручную создается логический интерфейс командой interface port-channel
  • Для интерфейсов 2го уровня логический интерфейс создается динамически
  • Для обоих типов интерфейсов необходимо вручную назначать интерфейс в EtherChannel. Для этого используется команда channel-group в режиме настройки интерфейса. Эта команда связывает вместе физические и логические порты

После того как настроен EtherChannel

  • изменения, которые применяются к port-channel интерфейсу, применяются ко всем физическим портам, которые присвоены этому port-channel интерфейсу
  • изменения, которые применяются к физическому порту влияют только на порт на котором были сделаны изменения

Синтаксис команды channel-group

Параметры команды:
active — Включить LACP,
passive — Включить LACP только если придет сообщение LACP,
desirable — Включить PAgP,
auto — Включить PAgP только если придет сообщение PAgP,
on — Включить только Etherchannel.

Комбинации режимов при которых поднимется EtherChannel:

Режим PAgP auto desirable
auto EtherChannel
desirable EtherChannel EtherChannel
Режим LACP passive active
passive EtherChannel
active EtherChannel EtherChannel
Читайте также:  Catalyst 2960 веб интерфейс

Интерфейсы в состоянии suspended

Если настройки физического интерфейса не совпадают с настройками агрегированного интерфейса, он переводится в состояние suspended. Это будет видно в нескольких командах.

Просмотр состояния интерфейсов:

sw# show etherchannel summary
sw1#sh etherchannel port-channel

Настройка EtherChannel 2го уровня

Настройка статического EtherChannel 2го уровня

Перед настройкой агрегирования лучше выключить физические интерфейсы. Достаточно отключить их с одной стороны (в примере на sw1), затем настроить агрегирование с двух сторон и включить интерфейсы.

Настройка EtherChannel на sw1:

sw1(config)# interface range f0/11-14
sw1(config-if-range)# shutdown
sw1(config-if-range)# channel-group 3 mode on Creating a port-channel interface Port-channel 3

sw2(config)# interface range f0/11-14
sw2(config-if-range)# channel-group 3 mode on Creating a port-channel interface Port-channel 3

Настройка EtherChannel 2го уровня с помощью LACP

sw1(config)# interface range f0/11-14
sw1(config-if-range)# shutdown
sw1(config-if-range)# channel-group 1 mode active Creating a port-channel interface Port-channel 1

sw2(config)# interface range f0/11-14
sw2(config-if-range)# channel-group 1 mode passive Creating a port-channel interface Port-channel 1

sw1(config)# interface range f0/11-14
sw1(config-if-range)# no shutdown

Standby-интерфейсы

Перед настройкой агрегирования лучше выключить физические интерфейсы. Достаточно отключить их с одной стороны (в примере на sw1), затем настроить агрегирование с двух сторон и включить интерфейсы.

Настройка EtherChannel на sw1:

sw1(config)# interface range f0/11-20
sw1(config-if-range)# shutdown
sw1(config-if-range)# channel-group 1 mode active Creating a port-channel interface Port-channel 1

sw2(config)# interface range f0/11-20
sw2(config-if-range)# channel-group 1 mode passive Creating a port-channel interface Port-channel 1

Настройка EtherChannel 2го уровня с помощью PAgP

Перед настройкой агрегирования лучше выключить физические интерфейсы. Достаточно отключить их с одной стороны (в примере на sw1), затем настроить агрегирование с двух сторон и включить интерфейсы.

Настройка EtherChannel на sw1:

sw1(config)# interface range f0/11-14
sw1(config-if-range)# shutdown
sw1(config-if-range)# channel-group 2 mode desirable Creating a port-channel interface Port-channel 2

sw2(config)# interface range f0/11-14
sw2(config-if-range)# channel-group 2 mode auto Creating a port-channel interface Port-channel 2

sw1(config)# interface range f0/11-14
sw1(config-if-range)# no shut

Настройка EtherChannel 3го уровня

Для EtherChannels 3го уровня IP-адрес присваивается логическому интерфейсу port-channel, а не физическим интерфейсам.

Перед настройкой агрегирования лучше выключить физические интерфейсы. Достаточно отключить их с одной стороны (в примере на sw1), затем настроить агрегирование с двух сторон и включить интерфейсы.

sw1(config)# int port-channel 2
sw1(config-if)# no switchport
sw1(config-if)# ip address 192.168.12.1 255.255.255.0

sw1(config)# int ran fa0/11 — 14
sw1(config-if-range)# shutdown
sw1(config-if-range)# no switchport
sw1(config-if-range)# channel-group 2 mode active

sw2(config)# int port-channel 2
sw2(config-if)# no switchport
sw2(config-if)# ip address 192.168.12.2 255.255.255.0

sw2(config)# int ran fa0/11 — 14
sw2(config-if-range)# no switchport s
w2(config-if-range)# channel-group 2 mode active

sw1(config)# int ran fa0/11 — 14 sw1(config-if-range)# no shutdown

Настройка агрегирования каналов на маршрутизаторе

R1(config)# interface port-channel 1
R1(config-if)# ip address 10.0.1.101 255.255.255.0

R1(config)# interface range fa0/0 — 1
R1(config-if-range)# channel-group 1 FastEthernet0/0 added as member-1 to port-channel1 FastEthernet0/1 added as member-2 to port-channel1

Пример настройки агрегирования каналов между коммутатором и маршрутизатором

Балансировка нагрузки

Метод балансировки нагрузки повлияет на распределение трафика во всех EtherChannel, которые созданы на коммутаторе.

Читайте также:  Роутер сколько компов можно

В зависимости от модели коммутатора, могут поддерживаться такие методы балансировки:

  • по MAC-адресу отправителя или MAC-адресу получателя или учитывая оба адреса
  • по IP-адресу отправителя или IP-адресу получателя или учитывая оба адреса
  • по номеру порта отправителя или номеру порта получателя или учитывая оба порта

Пример вариантов на коммутаторе 3560:

При выборе метода балансировки, необходимо учитывать топологию сети, каким образом передается трафик.

Например, на схеме, все устройства находятся в одном VLAN. Шлюз по умолчанию маршрутизатор R1.

Если коммутатор sw2 использует метод балансировки по MAC-адресу отправителя, то балансировка выполняться не будет, так как у всех фреймов MAC-адрес отправителя будет адрес маршрутизатора R1:

Аналогично, если коммутатор sw1 использует метод балансировки по MAC-адресу получателя, то балансировка выполняться не будет, так как у всех фреймов, которые будут проходить через агрегированный канал, MAC-адрес получателя будет адрес маршрутизатора R1:

Определение текущего метода балансировки:

sw1# show etherchannel load-balance

Тестирование балансировки нагрузки

Для того чтобы проверить через какой интерфейс, при настроенном методе балансировки, пойдет конкретный пакет или фрейм, можно использовать команду test etherchannel load-balance .

Проверка при задании IP-адресов:
Пример тестирования при задании MAC-адресов:

Источник